Archive

Posts Tagged ‘iso-scan’

Debian installieren – extrem

August 19th, 2009 3 comments

Die Aufgabe ist nicht besonders spannend: “Ein 32 Bit Debian Linux per USB-Stick auf ein Intel Atom 330 System (64 Bit) zu installieren”. Das das Ganze allerdings so viele Probleme machen kann, hätte ich nicht geglaubt. Vorab sei noch gesagt, das eine 64 Bit Version absolut Problemfrei funktioniert hat.

Wie man einen bootfähigen USB-Stick mit einer Debian Installation erzeugt, sei hier unterschlagen, dazu gibt es genügend Tutorials im Internet. Für Debian gibt es da eine Datei namens boot.img.gz was man mittels zcat auf den Stick überträgt. Beim booten stellt man recht früh fest, das der Installer kein Install-ISO findet.

Nun gut, sicher mein Fehler. Nach kurzer Recherche, um sicher zu gehen, einfach die mini.iso Datei mit auf den Stick kopiert – Neuversuch. Fail! Selber Fehler. Nach ein wenig rumprobieren stellt man also fest, das iso-scan zwar besagte Datei findet, aber meint das es sich nicht um eine Debian-Installation handelt. Blödsinn!

Also weiter rumprobieren mit diversen Versionen aller möglichen Dateien von Kernel bis hin zu Initrd … kein Erfolg. Als letzter Strohalm hab ich mir mal den Inhalt von mini.iso angeschaut und bis auf wenige Dateien sah das Bild genau so aus wie der Inhalt meines USB-Sticks. OK, also den Inhalt des ISOs auf meinen Stick kopiert und alles überschrieben. (Es dreht sich wohl sicher alles um die Dateien *isolinux*.)  Siehe da, es geht!

Blöderweise hat das Zusammenspiel von Hardware und Software mir dann doch noch ein Bein gestellt. Beim ersten Reboot steht im GRUB hd(1,0) statt hd(0,0) und sdb3 statt sda3. Blöd nur, das dass eigentlich der USB-Stick wäre 😉 Es hat dabei übrigens keinen Unterschied gemacht, ob der Stick angesteckt war oder nicht (Reihenfolge der Bezeichnung durch BIOS geändert, wäre plausibel für den Fehler) und wärend der Installation wurde auch korrekt auf sda instaliert…naja, Wayne… menu.lst und fstab angepasst und fertsch.

Das Ganze scheint wohl öffter aufzutreten, zumindest ist dieser BUG-Report meinem Problem sehr ähnlich, da auch bei mir das Unmounten Probleme gemacht hat.

Categories: linux, software Tags: , , ,