Archive

Archive for the ‘software’ Category

NFS export not mounted after reboot

March 5th, 2014 8 comments

Long story short: you have an NFS export and a proper configured /etc/fstab on your client. Mounting manually via mount -a works fine but nothing happens after reboot. Try to add the following to your /etc/default/rcS:

 ASYNCMOUNTNFS=no

cheers!

Categories: linux Tags: , , ,

NFSv4 and the seven Nobodies

March 5th, 2014 1 comment

I don’t know why this is still an issue on Debian/Linux machines but it is as annoying as it already was 2 years or more ago. Imagine you want to export /home via NFSv4 on a server so your clients can mount it remotely. Mostlikely, you will end up with lots of nobody:nogroup labeled entries, when you do a ls -la /home on your client. Check your logfiles and when you find something like:

rpc.idmapd[1905]: nss_getpwnam: name ‘USERNAME’ not found in domain ‘localdomain’

chance is high your idmap is not properly configured. This service is needed for NFSv4 as far as I know. Unfortunately, it is sometimes deactivated by default. Check /etc/defaults/nfs-common for this entry:

NEED_IDMAPD=yes

which also will tell NFS to start idmapd on startup. Next step is to adjust domain settings which depends on your setup.

  • Check DNS/DHCP server config, especially on correct domain name and it’s export if this is desired
  • Check if the client correctly receives and sets domain name (see lease-file and domainname-command for example)

Last but not least you need to check /etc/idmapd.conf to have this entry:

Domain = yourdomain

where yourdomain must be set properly. If you’re not sure about the DNS/DHCP config and/or receive a (none) by the domainname command, you want to go with localdomain as value here.

Do not forget to restart all reconfigured services and that should fix the issue.

Categories: linux Tags: , , , ,

OSX from a stick

February 5th, 2014 No comments

My macbook completely crashed today trying to recover from some severe file system corruptions. The symptoms were system freezes that took between 5-45 seconds each. Using Xcode was impossible so I did some tests and dsikutil tried to fix it – a non bootable OS was the result.

No problem, I have backups (timemachine + tivoli) and fast wifi at work so I rebooted into recovery mode using the option key but disk util failed to format my 2 partition disk (bootcamp) into 1 new file system because it claimed a disk still being mounted (which turned out to be the recovery image itself – rather stupid setup…).

So I needed a Mavericks boot stick. Downloaded OSX installer from the app store, waited patiently and then ran the following command:

sudo /Applications/Install\ OS\ X\ Mavericks.app/Contents/Resources/createinstallmedia --volume /Volumes/16GB --applicationpath /Applications/Install\ OS\ X\ Mavericks.app --nointeraction

with /Volumes/16GB being the mountpoint of the USB-Stick I used (that one will be formatted – You have been warned).

Again wait patiently for the process to finish (expect ~30mins depending on your thumbdrive-speed) and you should have a bootable Mavericks installer:

Erasing Disk: 0%... 10%... 20%... 30%...100%...
Copying installer files to disk...
Copy complete.
Making disk bootable...
Copying boot files...
Copy complete.
Done.

Categories: software Tags:

Rescue of a broken Parallels VM (Linux guest system)

October 31st, 2013 No comments

Something went terrible wrong. I upgraded form Parallels Desktop 6 to 9 to have my Ubuntu VM in Mac OSX 10.9. After the second boot of the VM I got a popup by Parallels: “your disk 7gb contains lots of unused space, would you like to compress to 2gb” or something like that.

My first thought was “hey, nice, a smart tool, which cares about users”. After lots of I/O and 10min later I had a second thought: “f**king bull**** software, i want my files back”. The VM was “gone”, every time I booted I got messages about missing sata devices. The VM hdd was corrupted (and still 7gb big).

Mounting the VM hdd in another VM didn’t help either, cause it didn’t even show up as a harddrive. And Murphy’s law hit me as always: I deleted a copy of the hdd earlier this day which I used to check a migration to virtualbox 🙁

Luckily Ubuntu (or at least a bunch of Linux tools) and the fact that I had only one etx4 partition helped me to restore the VM:

  1. Boot w/ a Linux live CD in the VM and run “parted /dev/sda” as suggested here
  2. Run “mklabel msdos” and “rescue 0% 100%” in parted (change 100% to something else if you have multiple partitions)
  3. Reoot w/ a Boot-Repair-Disk live CD in the VM to restore MBR, grup, …. as explained here
  4. Reboot w/o live CD and the VM hopefully works again (as it does in my case)

 

Summery:

  • Parallels Desktop 9 WTF???
  • Ubuntu/Linux *thumbs up* 😀
  • This writeup is not a general rescue guide, but worth a try if everything else fails.

Firefox 23+ Search in URL Bar

October 31st, 2013 1 comment

If you are a Firefox User you might have noticed, that something changed with the 23.0 Update. In former times, when you typed something in the URL bar (except an actually well formed URL) Firefox used Google search, independent of which search engine was selected at the top right search box. This changed with the 23.0 Version. Now the selected search engine from the search bar also is used for URL bar search. In my opinion this sucks.

But there is help, and it comes in the form of a little add-on called “keyword.URL Hack!”. You can install it from here: https://addons.mozilla.org/en-US/firefox/addon/keywordurl-hack/?src=api. After installation you have to change a setting in the about:config. To do this the following steps are necessary:

  1. Type “about:config” in your URL bar
  2. Accept the warning message
  3. Search for “keyword.URL”, if nothing shows up create an entry
  4. Right click in the empty space
  5. Select New -> String
  6. As an identifier type in “keyword.URL”
  7. In the next window type in “http://www.google.com/search?ie=UTF-8&sourceid=navclient&gfns=1&q=”
  8. Restart Firefox … thats all, now you can use Google as the default URL bar search engine

Why did Mozilla remove it? Well more or less because of security concerns. You can read the bugzilla entry here: https://bugzilla.mozilla.org/show_bug.cgi?id=738818

Categories: linux Tags: , , ,

Latexila: Latexmk -synctex=1 bad option

October 30th, 2013 3 comments

Hey there!
Some of you maybe also use Latexila to create their Latex documents. In the current version the predefined build commands fail with an error message

Latexmk: -synctex=1 bad option
...

I’m not sure if this is a mistake in the defined commands in Latexila or the options of Latexmk have changed. But anyway, the proper way to work around is to remove the synctex argument from the build commands within the GUI. Unfortunately, on my system (Debian Jessie – Latexila 2.8.3) the frontend immediately forgets about the changes.

Fortunately, we run an open system so one can modify the XML file which defines these commands. It’s location is:

/usr/share/latexila/build_tools.xml

We will see if this survives the next system update, cheers! 😉

Categories: linux, software Tags: , , ,

Medibuntu is Terminated

October 16th, 2013 No comments
Categories: linux Tags: , , ,

Number Replacement in Filenames

October 15th, 2013 1 comment

Just assume you have a lot of files with numbers in their names, but these numbers do not have leading zeros. How would you fix that?

rename 's/\d+/sprintf("%04d",$&)/e' *.FILEENDING

This command leaves the characters in the file name and replaces all numbers with the same number and leading zeros. Works with bash and ZSH, no warranty 😉 You also can replace the “04d” with “0Xd” and you get X digit numbers.

Todo.txt – Organizing Tasks nicely

October 6th, 2013 No comments

Everybody should know this feeling: lots of things to do…much more than a human can keep in mind…what the hell should I do?.
Obviously, we need some help to memorize and organize our activities. Since it can be a confusing path full of failure and religious discussions about pros and cons, I won’t talk about best practice or Getting Things Done; this is a personalized pilgrimage. Instead I will tell you about a nice little thing I came across while I tidied out my Gnome3 Extensions – Todo.txt.

It is a platform-independent, portable, plain-text approach to store tasks. Basically, there are two files on your computer’s or smartphone’s storage, a todo.txt and a done.txt, which are readable plain text files to keep open and closed activities. These files can be edited via an App, any editor, a command line interface, or as in my case a Gnome Extension. You can give your tasks personalized priorities, timestamps, related projects and locations as additional information to group and organize them as you need it.

Personally, I like the idea and the approach. The Gnome Extension looks good to me so far, because there’s a shortcut to open it and you can navigate and control it via your keyboard…and has fancy colors for priorities 😉 I will test it also on my Android phone and if it is as portable as it seems to me, I finally found a supplement to my old-school time planer notebook (yeah it’s made from paper!).

Categories: software Tags: , ,

Eve Online on Linux

October 1st, 2013 3 comments

A long time ago in a galaxy far, far away….there was a native Linux client for Eve Online. Someday, some bloody Sith decided to cancel further development. Since then, only a Windows client was officially available. If you were a hardcore nerd, you tried Wine to get things up and running. The result was depending on the versions of Wine and Eve itself.

I gave up using this setup years ago and walk through the dark and muddy paths of Windows to play my favorite game. Several time ago, a MAC client was introduced which basically is a WineX/Cedega shipped with Eve and I got hope CCP would start supporting such an approach in a way Linux would benefit from it too. Nothing like that happened so far…which makes me sad…

But today things changed a bit, because I got it Eve up and running again with Wine on an Intel HD 4600 grafics adapter. I will describe nearly all I’ve done, also stuff that didn’t work because Wine seams to behave a little randomly 😉 Here’s my setup:

  • Intel HD 4600
  • Debian GNU Linux Jessie (testing) with 3.10-3-amd64 kernel
  • Wine 1.4.1

My first approach was to build wine for 64-bit architectures from source, by adding –enable-win64 to the configure variables in the wineinstall script. But this didn’t work with the 32-bit binary of the Eve installer. So I’ve tried building a 32-bit Wine from source. Unfortunately, therefore you need several 32-bit libraries and their sources. They can be made available by adding i368 architecture support to system, which I describe next because it is needed anyway. The config.log file which is written during the configure process when you execute the wineinstall script (see Wine README for description) will give you hints about the missing libs.

To shorten this: I couldn’t get Eve working with this new version of Wine, which potentially does not mean it won’t since it is marked with Gold Status on the Wine website. Well I lost a little faith here so I removed all I had done so far and started from skretch with the Wine included in the APT packet pool. After a

sudo aptitude install wine

and executing it, you will be told that this isn’t a real wine installation because it currently is not natively available for 64-bit architectures. So you have to do a:

sudo dpkg –add-architecture i386
sudo aptitude install wine:i386

It is also necessary to get winetricks via:

wget http://winetricks.org/winetricks
chmod +x winetricks

When all this is done you need to start winetricks and install the following components (individually and ordered is prefered!)

  • corefonts
  • vcrun2005 (MS VC++ 2005 / MFC libs)
  • vcrun2008 (MS VC++ 2008 / MFC libs)
  • vcrun2010 (MS VC++ 2010 / MFC libs)
  • d3dx9_43 or newer d3dx9_36 also works if having trouble (DirectX 9)

I’m not sure if all the VC++ stuff is needed or just the actual one. But two things are very important here!

  1. DirectX has to be installed after VC++ libs ! I don’t know what the problem is, but doing DirecX first raises errors on vcrun installation and breaks things.
  2. After installing all this you need to change the order in which Wine uses the libs of MVC++ 2010. This does all the magic I needed to start Eve. Therefore start winecfg, navigate to the libraries tab, and set the state of the msvcr100 entry to (builtin,native) via the Edit button.

Now you can begin to install Eve Online. There are some minor bugs with missing text etc. But all works for me. The performance is a little bit poor but I think with a proper grafics card all is fine. There are also some D3D tweaks known to improve performance by adding them to the wine config. I haven’t tested this yet but I’m quite sure performance in general is getting better in the future.

Have fun and fly dangerously!

Categories: EvE, games, nerdcore, software Tags: , , ,